Announcement

Collapse
No announcement yet.

Importing Customers Generates Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Importing Customers Generates Error

    When I try to import my customers I get the following error:

    Error detected!
    Error: Wrong file format detected.

    I downloaded and filled in the sample file as instructed.

    I have made sure that the required fields are in there for each entry.

    In fact, just to try and simplify things as much as possible, I deleted all entries except for one, and I still get the error. The file is attached if anyone can offer some help.

    Thanks so much.

    Mike
    Attached Files
    www.KarensCookies.net
    Cookie Decorating Simplified

  • #2
    I have literally made the scenario as simple as possible. I download the file, open it, and fill in a single entry, only filling in the required fields, and I still get the error.

    I'm opening it up in Open Office Calc, using comma delimitation.
    www.KarensCookies.net
    Cookie Decorating Simplified

    Comment


    • #3
      Just off the top of my head, make sure line breaks didn't get changed somehow? That is one of the most common issues I have run into with automated import/exports.

      Comment


      • #4
        Thanks for the reply. I called support and they were able to import the file just fine. The only difference we could see is that they were using Excel while I was using Open Office.

        Well, I downloaded the trial version of Excel and it now works! (Yay!) That was a big one for me, so I'm happy to see a solution for that.

        Now there very well could be a setting within open office that will make it work, but I couldn't see it. If anyone is familiar with this, please post. Otherwise, let this thread help others who might be frustrated trying to use Open Office for their .csv files.

        Now I just have to hope that I'm done with all my importing before the trial runs out! :)
        www.KarensCookies.net
        Cookie Decorating Simplified

        Comment


        • #5
          Any plain text editor can work for CSVs, although may not let you do the same kind of bulk editing that an app like Excel would. I would recommend Notepad++. I am willing to bet you could also use Notepad++ to edit the OpenOffice version to make it useable. You could probably use it to compare the difference between the two files. I am willing to bet it has to do with line breaks.

          Comment


          • #6
            Noted. Thanks for the heads-up. I hope I'm done having to do this before my trial ends, but if I'm not I'll look into that app as another option.
            www.KarensCookies.net
            Cookie Decorating Simplified

            Comment


            • #7
              bump: OpenOffice Calc import

              Anybody ever find a way to get OpenOffice Calc .csv files to work?

              I'm frustrated with Excel because when it opens my .csv files it converts my UPC codes into scientific format. If I accidentally save the file without correcting, my UPC codes are consequently saved in the screwed up format. I'm so tired of Microsoft Office products deciding they know best what I need to do! If I have a cell with a 12 or 13 digit number in it, I'm pretty sure I'd like to keep that number intact! )

              OpenOffice Calc asks me how I want each row formatted before I open a .csv file.

              Comment


              • #8
                I Figured It Out!

                edit: This is not the best of all possible solutions - it creates errors if there are any commas in your content. So unless all of your content is comma-free, this method will not work... yet. I'm still working on it.

                What a way to waste an hour!

                To save your Open Office Calc file as a .csv that can import into 3dcart:
                1. When you go to File > Save As, be sure to check the box that says, "Edit filter settings." Then, in the next dialog box...
                2. Change the Character Set to: Unicode (UTF -7)
                3. Keep the Field Delimiter as a comma: ,
                4. Erase the Text Delimiter. It's a drop-down menu, yes, but you can delete the contents if you select them.
                5. Un-check the box that says "Save cell content as shown"


                I hope this helps others who are struggling with an Excel deficiency.
                Last edited by TMS Clint; 06-20-2011, 04:56 PM. Reason: WRONG
                Webmaster: Texas Media Systems

                Comment


                • #9
                  Beyond Frustrating

                  So here's the basic problem with importing a file created/modified in Open Office Calc...

                  It doesn't have the same .csv encoding as Excel. It doesn't have the right type of coding (naturally) to import directly into 3dcart. The settings in my previous post work with one caveat: no commas. If your fields contain any commas, then they start a new "row" as commas are the delimiter. This isn't a problem if the field is contained in quotation marks (text delimiter), but 3dcart can't process the file Open Office creates when you use a text delimiter.

                  I'm about to try a couple of "escape" characters in front of the commas that are part of a field ( / " ' \ * ), but I don't expect any of them to work. I'm also going to see if text delimiters will work in a different encoding (Unicode, Unicode UTF-8). I'm more hopeful about that.

                  Any thoughts on what to try would be helpful!
                  Webmaster: Texas Media Systems

                  Comment


                  • #10
                    We have Open Office installed on all 14 of our computers. Some of our computers import just fine while others do not. Its not the operating system as sometimes I forget that my laptop with vista gets the error. I take the file to a desktop vista using Open Office once again open and save and imports just fine.
                    So all I can truly say is the problem is within Open Office.
                    Wish you luck. Mean while the flash drive sure is handy for these mishaps.
                    .
                    Clayton
                    Go Live Industries

                    Comment


                    • #11
                      Thanks for the encouragement! None of my continued experiments succeeded. I've resorted to using Microsoft Excel Starter. I may revisit this problem at a later date as I do have more things to try.

                      If you've found this thread by searching for "Open Office," then know that I was creating a .csv specifically to import updated inventory. YMMV with other imports.
                      Webmaster: Texas Media Systems

                      Comment


                      • #12
                        All you open office fans that are unable to import.

                        Answer
                        Character set: Western Europe (ASC11/US)
                        Separated by: Comma

                        We too have been using Unicode8. Great for HTML not excel (open Office)
                        Hurray no more odd characters.
                        .
                        Clayton
                        Go Live Industries

                        Comment

                        Working...
                        X