Announcement

Collapse
No announcement yet.

Credit card section not showing!!!!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Credit card section not showing!!!!

    Is anyone else having this problem? When a customer clicks to go to the checkout page the credit card fields are hidden even though the radio button is selected.

    Is this because of the upgrade? Did something get broken when the upgrade was performed?

    I need help with this quick. We have had no orders for three days!!!!!!

    www.watchbandsolutions.com

    Thanks,
    Ken

  • #2
    Ours is working properly. Did you try reverting to an earlier version of your checkout page to see if that resolved it?
    Laura Z
    Brass & Silver Traditions
    www.brassandsilvertraditions.com

    Comment


    • #3
      Make sure your credit card customer group is set to "All" and your Country/State setting is set to "All-All". I learned this myself last week (found same topic in these forums with an explanation from Gil).

      If the "All-All" is not set, then the cart will wait to see where the customer is from before offering up payment options.

      Comment


      • #4
        I think I figured it out.

        On the Settings>General>Store Settings at the bottom there is something called "Enable Cache" I had never had this checked from day one so any changes I made to the site I could see right away. I read the info box on it and thought it would save on some bandwidth if it was checked. I checked it a few days ago and that must be why the credit card section didn't work.

        Don't enable the cache. That setting is worthless and should be removed from the cart.

        I unchecked it this morning thinking that may be what changed since I have not changed anything else on the cart for weeks. Sure enough it shows now and we have orders again.

        If anyone from 3dcart reads these posts you guys broke this setting or need to remove it as it is worthless. It cannot be used without making it impossible to receive payment for orders!!!

        Maybe this was an intentional change to the cart so people are forced to spend more on bandwidth.

        Thanks brassandsilver and burnspot.

        Ken

        Comment


        • #5
          Yours wasn't working yesterday and is now. If I clicked another method then selected CC it worked. Was thinking of suggesting removing the "checked" code on your template so they would have to select the payment method.

          That being said I couldn't see a difference between your parsed code and ours but our cache is enabled and works fine

          Comment


          • #6
            Originally posted by mondo View Post
            Yours wasn't working yesterday and is now. If I clicked another method then selected CC it worked. Was thinking of suggesting removing the "checked" code on your template so they would have to select the payment method.

            That being said I couldn't see a difference between your parsed code and ours but our cache is enabled and works fine
            Yep, no problems with using the cache here either, it's a habit to "flush the cache" whenever making any template edits or changes to things other than "system language" (which seems to reset the cache upon saving). ;)

            3D's cache usage is similar to that of many of the content management system's out there which advise disabling the cache during "development" so that changes can be immediately seen. 3D's own "tooltip" on the cache setting advises the same thing.

            Comment


            • #7
              I've no problems with using cache either. Just remember to flush the cache when you make changes.

              Comment


              • #8
                I've actually made it a rule of thumb to dumb cache whenever changes are made. It is absolute habit now. And not a bad habit to have.

                Comment


                • #9
                  Thanks for the info guys. I don't think I did that when I checked the cache.

                  Ken

                  Comment

                  Working...
                  X