Announcement

Collapse
No announcement yet.

Left-Nav sub-categories caching

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Left-Nav sub-categories caching

    In our store settings, under "Main Store Settings" we had "Show from selected Cat only" clicked ON. However, when browsing the store, the subcats get stuck on whichever one is displayed first (the first subcat displayed will remain open even when you navigate to other categories.) In fact, the only way to unstick the subcat is to clear the cache on the backend.

    We turned off caching for a while and the nav then worked correctly, but we don't want to leave caching off, so that is not a good solution.

    I don't see anyone else with this issue, so am I missing a step? could I have messed something up in my frame template? any ideas?

    Our site is
    The Watch Prince


    Thanks, mimi
    Last edited by mimib; 06-06-2011, 04:00 PM.

  • #2
    I just browsed through a bunch of your categories and subcategories. No problems at all. All the ladies sub-cats displayed correctly until I switched over to diver watches, then the diver sub-cats displayed, then switched to crocodile and the sub-cats switched correctly again. Everything looked ok from my end. :)

    Comment


    • #3
      I turned off caching again right before I left work yesterday because I really want those subcats to display. So it is still broken with caching on.

      Comment


      • #4
        i see no issue on my computer either. I click on a few of your cats on the left side, then clicked into a sub cat, then moved on to a new cat and it looked good..

        maybe you need to clear the cache in your browser

        I remember in your other thread you had problems with people not converting after you turned your store on. Have things gone back to normal since going live with 3dcart?

        Comment


        • #5
          Thanks for checking, but I think maybe I didn't explain it clearly enough.

          It's working now, because I have disabled caching in the admin (settings/general/store settings/store url: "enable cache" unclicked)

          If I click "enable cache" on, the left nav subcats stick. The only way to unstick them is to go back to settings/general/store settings/store url and hit the "clear cache" button. But then, it will stick again as soon as another subcat is opened.

          I am fine with leaving "enable cache" unclicked (as it is now), but our bandwith usage is climbing and I read in another thread that caching cuts down on bandwidth usage as well speeding up page loads.

          --
          guod-- thanks for asking about our sales since the switch. unfortunately we have a long way to go to get back to pre-switch sales, but they are (slowly) increasing day-by-day. our redirects are working like a charm, we're doing well on google, and 3dCart's site search works waaayyyy better than our netsuite site search ever worked, but the sales are still way low. still can't identify just what's holding people back.

          Comment


          • #6
            Originally posted by mimib View Post
            Thanks for checking, but I think maybe I didn't explain it clearly enough.

            It's working now, because I have disabled caching in the admin (settings/general/store settings/store url: "enable cache" unclicked)

            If I click "enable cache" on, the left nav subcats stick. The only way to unstick them is to go back to settings/general/store settings/store url and hit the "clear cache" button. But then, it will stick again as soon as another subcat is opened.

            I am fine with leaving "enable cache" unclicked (as it is now), but our bandwith usage is climbing and I read in another thread that caching cuts down on bandwidth usage as well speeding up page loads.

            --
            guod-- thanks for asking about our sales since the switch. unfortunately we have a long way to go to get back to pre-switch sales, but they are (slowly) increasing day-by-day. our redirects are working like a charm, we're doing well on google, and 3dCart's site search works waaayyyy better than our netsuite site search ever worked, but the sales are still way low. still can't identify just what's holding people back.
            When I had issues, 3dcart always told me to keep caching off. I was not aware that it could help consume bandwidth. Maybe now that our design is pretty solid, I can turn it on? We shall see.

            In your case, how much bandwidth are you using that you would want to turn it on to save? I mean the $99.99 a month package gives you "40,000" people right? It is more than enough for us, but IDK your store is probably very different. Maybe you need to switch to a dedicated hosting package, allowing you to leaving caching off and avoid bandwidth overages..
            Last edited by guod; 06-07-2011, 01:58 PM.

            Comment


            • #7
              .... about our sales since the switch. unfortunately we have a long way to go to get back to pre-switch sales, but they are (slowly) increasing day-by-day. our redirects are working like a charm, we're doing well on google, and 3dCart's site search works waaayyyy better than our netsuite site search ever worked, but the sales are still way low. still can't identify just what's holding people back.
              Is it your sales are down or your traffic is down? Or both? Are you noticing more abandoned carts (assuming you could track this with your old site)? Are you getting more or less phone calls/orders? Is your advertising the same as before?
              Some of these answers may point you in the right direction!
              Last edited by Barry; 06-07-2011, 03:00 PM.

              Comment


              • #8
                Originally posted by mimib View Post
                I turned off caching again right before I left work yesterday because I really want those subcats to display. So it is still broken with caching on.
                It's kinda hard to help you if you prevent us from seeing the problem..... :(

                Comment


                • #9
                  Originally posted by piaf View Post
                  It's kinda hard to help you if you prevent us from seeing the problem..... :(
                  I doubt the OP wants to leave up a broken page though...I guess it is sort of a catch 22 haha

                  Comment

                  Working...
                  X