Announcement

Collapse
No announcement yet.

Really frustrated.....

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Really frustrated.....

    Yesterday I started to slowly roll out some of the new features in V4, so I decided to start with the Quick View & Quick Cart. In testing how these features looked and played nice on my site, I realized strange things happening. For example, clicking on a related item in my product listing page would take someone to a "logging out of your account error". :confused:

    So, after breaking my head reviewing the store settings, I went to template editor and lo & behold my listing templates have been edited on July 20th by 3dCart Support, apparently preparing my site for the upgrade. Problem is, I don't know what they added, deleted, moved and why? (There are many changes showing when I do a compare of my last template and 3dCartSupport's template) I was never told that they would physically go in and edit my templates. How am I supposed to start comparing each customized template and figure out what is causing the problem? I don't have this kind of time. :mad:

    I'll be putting in a call to support, but this is extremely unfortunate and I think 3D should spend the time getting my site back in working order.

    /RANT
    Last edited by cosmic; 07-28-2011, 07:59 AM.

  • #2
    Cosmic, do you keep a copy of the latest functional template HTML changes on your local computer? If so, just upload your last saved template changes to get back to the working version you had prior to the changes made by 3dCart.

    And I agree, if 3dCart is making changes to ANYONE'S site, they ought to be notifying you about it first.

    Comment


    • #3
      Holly cow!!! That is no good. Keep us posted on the outcome.

      I have been away and need to work with the new upgrades, but may be I will wait until all the bugs are fixed...

      Uta

      Comment


      • #4
        Originally posted by piaf View Post
        Cosmic, do you keep a copy of the latest functional template HTML changes on your local computer? If so, just upload your last saved template changes to get back to the working version you had prior to the changes made by 3dCart.

        And I agree, if 3dCart is making changes to ANYONE'S site, they ought to be notifying you about it first.
        I still haven't heard back yet and so this morning I reverted to my last template revision.... but the problem still exists.

        I was thinking that maybe there may need to be some revisions (additions) to the frame with the V4 upgrade since mine was customizeed, so after FTP, when I went to look in the templates folder for examples of the V4 layouts or a common frame layout, I have nothing (no common frame template and no V4 layouts to use as a reference).

        BTW, in addition my product sort does not work at all.

        I want my V3.2 back, because I feel lost right now. The more I attempt to "fix" things, the more confused I am getting.

        Comment


        • #5
          Yeah, I had the same problem. I wanted to save a copy of the V4 frame from the common folder onto my local drive in case of an emergency, but when I went to go look for it, it wasn't there. So I have no point of reference for V4. Not good.

          Comment


          • #6
            It's not just my site apparently!

            Hate to be the bearer of bad news, but in my quest to find an answer I visited some other 3D sites and have confirmed that on 2 of the 3 I visited, the same thing happens with IE and Chrome.

            Here is the exact order of things:

            Visit a product page that has related items and click Add to Bag/Buy and it takes you to an "error.asp?error=53 page" - Log Out -You have successfully logged out from your account.

            FYI, It's approaching 4:30 pm on a Friday (heading into the weekend) and no new update on my ticket since yesterday morning. :(

            Comment


            • #7
              Originally posted by cosmic View Post
              Visit a product page that has related items and click Add to Bag/Buy and it takes you to an "error.asp?error=53 page" - Log Out -You have successfully logged out from your account.
              FWIW I'm on V4, just went through your process, and did not get an error.

              I don't know if it matters but I'm on multi-page checkout.

              Comment


              • #8
                Originally posted by Evolution View Post
                FWIW I'm on V4, just went through your process, and did not get an error.

                I don't know if it matters but I'm on multi-page checkout.
                I'm not sure the checkout (I use 1-page) would be a factor. Do you have your related items set up to add directly to the cart or do they go to the product detail page? Mine were supposed to add directly to the cart and use the following code, which originally came in a 3D template:

                Code:
                <tr>
                                    <td class="item" align="center"><input  type="button" value="[category_buyitlink]" onClick="window.location='add_cart.asp?quick=1&item_id=[catalogid]'" class="btn" onMouseOver="this.className='btn_over'" onMouseOut="this.className='btn'"></td>
                                  </tr

                Comment


                • #9
                  There's another post about this same snippet of code malfunctioning... you can find it at http://forums.3dcart.com/general-con...asp-links.html

                  For some reason, that code is working ok on our site, but maybe different store configurations are causing it to have issues.

                  Comment


                  • #10
                    Originally posted by piaf View Post
                    There's another post about this same snippet of code malfunctioning... you can find it at http://forums.3dcart.com/general-con...asp-links.html

                    For some reason, that code is working ok on our site, but maybe different store configurations are causing it to have issues.
                    Thank you Piaf!! :)

                    Although my problem wasn't related to the thread you noted (none of our products have options), it forced me to look at the code in Advanced, which is different than the code for related items that came from an original 3D listing template. :confused:.

                    Anyway, I replaced the code with
                    Code:
                    window.location='add_cart.asp?out=1&quick=1&item_id=[catalogid]
                    and now it works.

                    Comment


                    • #11
                      Glad I could help. :)

                      Comment

                      Working...
                      X