Announcement

Collapse
No announcement yet.

My "product_social_bookmarking" code is continually reverting back to a default code

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • My "product_social_bookmarking" code is continually reverting back to a default code

    Just about every day, I have to go into Settings > Design > Store Language and update the field called product_social_bookmarking. 3dCart inserts some sort of default AddThis code in there and I have chosen to customize that code to display different widgets other than the default widgets. But it seems that the code "reverts" back to the default code on a VERY regular basis, and I'm constantly checking my website to see if the widgets are the ones I've chosen to display or if they're the default ones that 3dCart has set up. Seems like every other day or so, I'm having to update the AddThis code in that field to MY chosen code rather than the 3dCart version of the code that it seems to continually revert back to.

    Is anyone else having this problem?

  • #2
    Originally posted by piaf View Post
    Just about every day, I have to go into Settings > Design > Store Language and update the field called product_social_bookmarking. 3dCart inserts some sort of default AddThis code in there and I have chosen to customize that code to display different widgets other than the default widgets. But it seems that the code "reverts" back to the default code on a VERY regular basis, and I'm constantly checking my website to see if the widgets are the ones I've chosen to display or if they're the default ones that 3dCart has set up. Seems like every other day or so, I'm having to update the AddThis code in that field to MY chosen code rather than the 3dCart version of the code that it seems to continually revert back to.

    Is anyone else having this problem?
    I haven't had this problem but I will certainly help you fix it.
    go to: socialcommerce>socialbookmarking
    click on advanced, this is where you need to make your edits.
    I should note that sometimes when a customer is logged in and shops that sometimes the site remains secure so make sure to update the url to https to avoid unsecure issues.
    <a href="https://addthis.com/bookmark.php

    Rock on!
    .
    Clayton
    Go Live Industries

    Comment


    • #3
      I personally prefer to remove the reference and hand code the code.
      This can be done by removing:
      Code:
      <!--START: product_social-bookmarking-->
                              <td align="left">[product_social-bookmarking]</td>
                              <!--END: product_social-bookmarking-->
      And hand code within the <td> tags.

      I don't like to comment out. Less referance = faster loading site.

      Good Luck!
      .
      Clayton
      Go Live Industries

      Comment


      • #4
        I've added the code to the other location you mentioned in your first reply, so we'll see if that resolves the problem. Thanks! :D

        Comment


        • #5
          Interestingly, the Settings > Design > Store Language > product_social_bookmarking field has once again reset itself to the "default" which I don't want to use (I prefer a different set of buttons on my AddThis code). I guess I need to submit a ticket to find out why the heck this keeps getting reset. :mad:

          Comment


          • #6
            I have the same problem and got this from support
            Hello,
            One guaranteed way to prevent the social bookmarking app from popping up on your site would be to remove it from your listing template altogether. It appears that most (all?) of your products use listing_0.html / Default as the listing template/Style. Therefore, you can go to Settings > Design > Template Editor > listing_0.html Edit button to open the html code for the listing page. You can then delete the codeblock that refers to the SocialBookmarking feature. I have attached a screenshot that highlights the code to be removed.

            Once saved, go to Settings > General > Store Settings > scroll to bottom of page, click Clear Cache button. Then refresh your browser and you will no longer see a Bookmarking app at any time.

            Capture | Flickr - Photo Sharing!
            http://www.canadianghosthuntersupplies.ca

            Comment


            • #7
              I don't want to PREVENT the social bookmarking from showing up on my site. I DO WANT IT there. I just don't want the code that sets it up on my site to change (without me changing it) like it's been doing.

              It starts out as a default code on the Store Language page, then I change it to the code I want, then a few days later, it goes back to the default code (on its own??), then I go back to the Store Language page to change it how I want it again, then a few days later, it reverts back again to the default code (on its own again??) .... and on and on and on. There's nothing happening with the templates in my situation and I'm not trying to get rid of it altogether.

              Comment


              • #8
                I think what support was trying to say is to delete the call for the stored social bookmarking code and to insert your code to the template page itself.

                Look for... [product_social-bookmarking] in your listing template and replace this code with your actual social bookmarking code.

                Comment


                • #9
                  Ahhh, ok, I see your point. I submitted a support ticket and support assures me this won't happen any more. So I'll wait and see. I like to avoid needless template modifications whenever possible, but I guess if the problem continues, I'll have to go that route.

                  Comment


                  • #10
                    i have the exact same problem

                    Comment


                    • #11
                      Originally posted by guod View Post
                      i have the exact same problem
                      guod, contact support and open a ticket. You can have them refer to ticket number EMO-710827 to see what they did to my system to fix it. It hasn't reset back to the default yet (since August 25th) so maybe they actually fixed mine.

                      Comment


                      • #12
                        will do.

                        thanks!

                        Comment


                        • #13
                          Well, I spoke too soon. It reverted back to the "default" setting again either yesterday or today. :mad:

                          Comment

                          Working...
                          X