Announcement

Collapse
No announcement yet.

Daily Deal Causing Unsecured page

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Daily Deal Causing Unsecured page

    Using template v32020 which shows the inside of the cart on all pages in the right column, and when using the Dail Deal with this template, if someone puts items in the cart and purchases, the page will come up with a pop up for being unsecured. This template does not have an inside the cart page, and uses the right column of the template. I took everything off the page until I figured out what was causing it, and it was definitely the Daily Deal. So I have removed the Daily Deal. I really want to use it. Does anyone have any ideas on what to do?

  • #2
    The Daily Deal CANNOT go on the panels (left or right) if you show those panels in the checkout page. The cause is the social media script on the widget.
    If you must have this on either of the panels, hide the panel in the checkout page. Settings>Design>Title & Contetns : Edit the checkout page and check off the appropriate "Hide ____ Panel"
    Elegant Weddings +
    www.elegantweddingsplus.ca
    www.elegantweddingsplus.com

    Comment


    • #3
      In this template there is not a cart page so that you can hide the column. The cart is actually part of the right column. From there it goes straight to checkout. If you don't put the Daily Deal in either column, are you making a page specifically for the Daily Deal?

      Comment


      • #4
        The instructions from the 3DCart knowlegebase specified adding these widgets on the home page (not on either panel)

        I use the exact same template you are using for one of my sites, and I have the minicart you mentioned. I did have the Daily Deal and Group Deal Widgets on the right column, but, did not have the unsecure content problem on the mini cart. Currently I have the widgets displayed on the OnSale page for esthetic reasons.

        If you are having problems check to see if your site is "https" instead of "http". The "s" should only appear on the checkoutpage of the site and Account pages.
        Elegant Weddings +
        www.elegantweddingsplus.ca
        www.elegantweddingsplus.com

        Comment


        • #5
          Thank you!

          Comment


          • #6
            Originally posted by DCRCreations View Post
            In this template there is not a cart page so that you can hide the column. The cart is actually part of the right column. From there it goes straight to checkout. If you don't put the Daily Deal in either column, are you making a page specifically for the Daily Deal?
            I use template v32020 and I have a view cart page. Your template may not have a link anywhere to the view cart page, but the page is there and you can add a link to it from your navigation or from your mini-cart over in the right column. The link to your cart would be: /view_cart.asp

            If you want to see how mine looks, send me an IM and I'll send you the link to my store.

            Comment


            • #7
              After all this time, I finally found out it was not the Daily Deal, it was my Facebook Badge!

              Comment


              • #8
                I ran into the same problem some time ago and found out I had an image that had httpS - frustratingly easy fix - but took a while to find it - Tech support located it for me. Was VERY glad to get it fixed as it is disconcerting to the customer to see those 'security' messages.
                C Ekman
                Owner/Designer: Cobweb Corner
                http://www.cobwebcorner.com

                Comment


                • #9
                  Hi all,

                  I couldn't find the original thread, but one of our users recently posted a VERY helpful link that might help with future issues like this and finding any possible unsecured elements that can pop up from time to time.

                  Why is my SSL web page insecure? Find the culprit!

                  Hopefully it helps other users who might come across this thread in the future.

                  Comment


                  • #10
                    That's a helpful link!
                    It also shows that the "addthis" in the Daily Deal widget can cause that security flag.

                    Comment


                    • #11
                      you can make your daily deal widget secured. Mine is (I believe it was even before i removed the addthis box)

                      https://www.wishack.com/

                      If you have any questions on how do secure it i'd be happy to try and help.

                      Comment


                      • #12
                        Mine's also reporting as insecure. I removed it previously because of that, but I really do like the feature because I do sell my daily deals...I'd be interested in how to?? And appreciative of ANY assistance

                        Comment


                        • #13
                          you probably have to remove or modify the the "addthis" social media stuff.

                          Comment


                          • #14
                            addthis supplies a secure login option (add https:// instead of http://)

                            TooBusy... I'll go open up an unmodified dd_widget today and try and copy out the code i changed.

                            Comment


                            • #15
                              Hi there

                              I've had mine working in the left hand sidebar for a while now. I had to make a few changes to the template file related to the images to solve the secure page error, along with changing the header to suite my own needs.

                              If you're still struggling I can take a look at my template file and let you know what I did. I remember resizing the widget was fun and games but I can re-visit if it will help you out.

                              Phil
                              Golf Tees Etc
                              www.golfteesetc.com

                              Comment

                              Working...
                              X