Announcement

Collapse
No announcement yet.

Not able to import NOTFORSALE field

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Not able to import NOTFORSALE field

    once upon a time we used to be able to export out products, change the state of NOTFORSALE from 0 to 1, and product would no longer be available for purchase online.

    Is this function gone now? When i try the old way (export products file, change field, import new file) it just times out.

    investigating, i see that now there is a link to 'sample file' in the import area of the import/export page. this file is in a completely different format than the exported file. and, worse--now many of the fields that may have been exported are no longer eligible for import--NOTFORSALE being one of them.

    if this feature/function has been removed, is there a viable replacement/workaround?

  • #2
    What happens if you take the sample import file and add a notforsale column to it? I am quite sure that you can still import this field.

    Comment


    • #3
      the problem was i work in a multi-os envronment, and i happened to be using a mac at the time when i was adjusting the excel file. there is no option to save as a MS-DOS CSV file (apparently the CSV that mac writes uses a different character set???)

      so #1 the exported file CAN be used as the import file--but, must be saved from PC
      #2 (as advised by tech support) the provided sample import file is old, out of date, and he was not sure why it was still provided.
      #3 tried just adding the NOTFORSALE field to the sample import file, and it did not work.

      Comment


      • #4
        There are a lot of ways to fix the line-endings problem on your Mac. I use TextWrangler. Open up the CSV file, change the line-endings from Unix to Windows, and re-save.

        Comment


        • #5
          Originally posted by cbsteven View Post
          There are a lot of ways to fix the line-endings problem on your Mac. I use TextWrangler. Open up the CSV file, change the line-endings from Unix to Windows, and re-save.
          thanks. good to keep in mind. in this case i was already on an RDC session to our terminal server. so, just as easy to save as a windows CSV.

          Comment

          Working...
          X