Announcement

Collapse
No announcement yet.

Daily Deal Problem ??

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Daily Deal Problem ??

    For those of you using the Daily Deal/Deal of the Day , have you tried to link to your page from Facebook?

    It was brought to my attention today that since switching over to using the Daily Deal, my "Facebook Friday" pages can not be accessed from FB on portable devices.

    I tested this on an Android tablet, iPad, and iPhone and confirmed that, when a user clicks on the link I post in my Facebook post, it tries to open a page but is blank. When clicking on the link from a PC/Laptop everything works fine.

    I also verified that all of ther cart links on FB open up the page correctly, it's only the page with the Daily Deal that won't open.

  • #2
    Can you give an example link that does not work?

    Comment


    • #3
      If you visit the FB page http://www.facebook.com/cyclenutz and click on the Facebook Friday link you'll see the issue.

      Comment


      • #4
        The link is:
        Code:
        http://www.cyclenutz.com/Facebook-Friday_ep_56-1.html
        the problem is when you visit from a mobile site it is directing you to
        Code:
        http://www.cyclenutz.com/mobile/Facebook-Friday_ep_56-1.html
        I am not sure what the fix is off hand but it clearly has something to do with the mobile site not having this extra page that your full site has. You could turn off your mobile site entirely. I dunno. I don't use a mobile site.

        My recommended solution is to link instead to:

        Code:
        http://www.cyclenutz.com/product.asp?dailydeal=1
        This will redirect them directly to the sale page, so they won't have to go through the intermediate page where they have to click yet another link to get to the product details. I tested this and it does work on mobile.

        Comment


        • #5
          Great catch cb.. I think you're on to something.

          The odd thing is I turned mobile off, turned off advanced cache, cleared cache, turned cache back on and still get the same issue.

          In fact, I tried typing the posted url in manually and it still redirected to mobile.

          I opened a ticked with support early this morning but haven't heard back. I'll have to update the ticket with your finding.

          Comment


          • #6
            Even if I go directly to cyclenutz.com from my iPhone, it still transfers me to the cyclenutz.com/mobile area. Maybe it takes some time for the 3DCart servers to change the mobile redirections.
            Joanne Barker
            VS Web Design
            [email protected]

            Comment


            • #7
              Hi Evolution,

              I'm sorry to hear that you're having issues with this feature. I'm going to speak to the Support Manager in regards to your open ticket FNQ-524-20694.I'll make sure that someone replies to you shortly.

              Sincerely
              Fernando- Chief Customer Officer
              3dcart

              Comment


              • #8
                Thanks Fernando.. I've turned off mobile, even removed the script.

                I tried to use a manual redirect with no luck also.

                Comment


                • #9
                  20ish hours before a reply on a ticket that was opened with a HOT priority.

                  Disabled the FB promote on that since I'm just wasting money at this point.

                  Comment


                  • #10
                    Evolution, did you also remove the re-direct tag from your frame.html when you disabled the mobile site?
                    That could cause the re-direct.

                    look for :
                    Code:
                    detect.js">

                    Comment


                    • #11
                      Yes, it was in our footer and I removed all evidence of the code.

                      Comment


                      • #12
                        What about using what I called my "recommended solution" in my post above? Change the link you are posting to the one that takes customers directly to the product page instead of the intermediate page. Probably get a higher conversion rate that way anyway.

                        Comment


                        • #13
                          I'll probably do that in the future but am waiting to see if Support has a workaround for the links that already exist on the wall.

                          Originally posted by cbsteven View Post
                          What about using what I called my "recommended solution" in my post above? Change the link you are posting to the one that takes customers directly to the product page instead of the intermediate page. Probably get a higher conversion rate that way anyway.

                          Comment


                          • #14
                            Well Support got it wrapped up yesterday and it boils down to there are no mobile templates for created pages.

                            CB's solution may be an option in the future. For now, I'm taking the high road on the mobile version. It was quite the task just to get it to work and I've got to re-evaluate if it's really worth it to have bugs like this creeping up when it's in use.

                            Thanks again for the tips in the troubleshooting.

                            Comment

                            Working...
                            X