Announcement

Collapse
No announcement yet.

Questions on Responsive Template

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Questions on Responsive Template

    OK folks. Some of you are going to shake your heads and some will nod. But, I'm going to start listing all of the questions I have. It's time. Google is here and I don't have time to go to school.

    1) When email templates are changed, why do they have to overwrite my custom text? Frankly, I don't want to shout at my customers. Putting the customer's name in 40 px and the balance of the email in 12px is insane. We have custom text in the shipping emails, in the new order email, etc. I've had to rewrite them twice now.

    2) Header space: Why does the header have to be so big? It takes up 2.5" on my monitor. The products are MUCH MORE important than our logo. Customers have to scroll down to see the products. OMG. And, I can't figure out how to change it.

    3) Search button: Why the heck doesn't the search button work? I did nothing. It now doesn't work. Was this changed by 3dcart in one of their fixes? Anyway, if someone has a suggestion, I beg you, please share it. Even I can't find the product for my customer. Customer: "I have a question about Widget 2241. Me to customer: "I can't search for it so I can't find it. Go shop at another store."

    4) Category not closing: Why doesn't it close on my iPhone? The customer would like to see the product (surprise). It covers the menu button so it can't be closed. (BTW, it works just fine on the dynamic screen on my desktop. It just happens in real life, like when the customer is actually using a phone. Good luck, customer. I can't figure it out either. Message to my customer: "Go shop at another store."

    5) Screen on phone: Amazon's web on iPhone fits exactly in the screen. My shows up with a black background which came with template. Can't remove the background. The customer has to be smart enough to scroll way to the left. Message to my customer: "Go shop at another store. "

    OK. Maybe someone who helped me modified this and I don't know it. But if there is a fix, it's being kept a secret from me. Why is some text labeled "element"? Are we in science class? That doesn't make sense, except if you're in an exclusive club that understands this. Where is the code list? (i.e., translation: element = text in menus, etc.). Now I may be wrong about this. But I tried another template. It appears that other than the standard H2 and body text, they used different classes for the same thing.
    Last edited by Davef; 04-17-2015, 10:46 AM.

  • #2
    Your #1, I'm not quite sure what you're referencing, so I can't be of help there. However, I share a plethora of issues with the Responsive theme that I purchased as well (I decided on the Chic Lumber template).

    Your #2, I wonder the same thing. On my HTC One, the header takes up a decent amount of space, and not sure why it has to be so large when down to the mobile level (and thus take up so much valuable space).

    Your #3, I had the same issues. Open a support ticket, they should* be able to help resolve that issue.

    *I say "should" because they fixed it on my website, and then I don't know what happened, but it's not working again. I did change the header and/or disabled Quick Search, but left the raw search code untouched and it's not working again....new ticket is in, hopefully they'll be able to fix it (again). Something strange about the Quick Search (which I did NOT want enabled because it does NOT render nicely on mobile phones), and when you disable quick search it screws up the search function. I'm not sure, but something is definitely amiss with the search functionality of the template I'm using.

    ​Your #4, same thing on my HTC One. When you click the menu bar (?...if that's what it's called...the three lines stacked horizontally) it covers up the entire left side of the screen. The only way to close it, besides actually clicking something within the menu links or categories, is to randomly click somewhere on the right side of the screen, away from the bar. Poorly thought design, not sure at all how to fix it....

    Your #5, I don't think I'm experiencing the same issue, though I don't have an iPhone handy to test. Is there a way for me to see what you're talking about without owning or using an iPhone? Like a website that shows how your site renders on different devices (I've been too afraid to click on those in search results, because who knows how many are littered with a virus or something).


    Other issues that I've experienced that you perhaps were lucky enough to not have:

    1) Multi-step checkout (Step 3) did NOT show sales tax on the order. So it would read something like:

    Subtotal: $5.00
    Shipping: $5.00
    TOTAL: $10.70

    See how that doesn't add up? Because the sales tax line was never written in the code to begin with. It was, however, coded in the Single Page checkout template, but overlooked for multi-step checkout (Step 3). After support replied to my ticket by basically sending me a link to a gigantic list of codes used by 3D Cart, you know, so that I'd have to guess at how to do it without any true coding experience, I figured out how to just copy the 2 lines from the single page checkout and enter it in the Checkout Step 3 code. Tested. Works. Done. Geez...

    2) If you have a product with options, and you have "more info" for the option (you know, where it shows the Question Mark in the circle that you can click for more info), the background was completely transparent and you could not read the words in the info box. A ticket submitted led to a quick resolution, though.

    3) Address Validator did not work in multi step checkout. Got hung up endlessly going from Checkout Step_1 to Checkout Step_2. Support said they did in fact diagnose that it was related to the Address Validator plug-in that I purchased. They advised that it DID work on single page checkout (which it did), but that if I wanted to continue using multi step checkout (my overwhelming preference), I would have to disable the plug-in until they're able to diagnose and possibly correct the issue (and so I did, and to which I still haven't heard back if there is a fix for it).


    Honestly, I originally used a free HTML5 Responsive template and it was FULL of bugs (even more so than what we've covered here on the premium templates!). Their reply to my ticket about the issues was that I should purchase a premium responsive template because they've all been tested for functionality and are much better. While, yes, they were much better than the free ones, I don't see how they were fully tested when things like what we've covered here are present. I've spent a good deal of money with Shaun @ TheCartDesigner (who is awesome, by the way) and something tells me I'm not done needing his help yet. In the end, this responsive template will cost significantly more than I had originally anticipated.

    There you go, my 2 cents. I would like to end with the fact that I do like 3DCart, and their service is generally very good. I just feel slightly misled when I was advised that their responsive templates (premium ones, that is....the ones that you pay money for) were tested for functionality when in fact there are several issues that are either blatantly overlooked or just poorly designed to begin with. Perhaps that's just the theme that I ended up using (Chic Lumber)...

    -James

    Comment


    • #3
      Thanks for your response. I'm using the Chic template as well. It's a bit of a comfort knowing that someone else is having the same questions.
      #2: Large header: I'm glad you agree. Maybe someone can suggest a fix. I wonder if it's limited to Chic.
      #3: Search Button: I thought it was the Quick Search too. Turned off, thought it was fixed, and then broken again. I'll put in a ticket as well. Two of us having the same problem. I have another store and there is no problem with that template's search feature. The developer should fix it.
      #4: Category bar covering the entire screen. It appears to be a 3D cart issue. My other template doesn't do that.
      #5: Wobbly screen. I'll send you a text and perhaps you can test it on your phone.

      1) Multistep checkout. Geesh. Thanks for the heads up.
      2) More info help (?): Don't use that but the tabs were unreadable until the tab colors were changed. The designer should have checked that.

      Shaun has been helping me too. He's been wonderful. He's been working on the Search problem but no success yet. His skill level is excellent so there is a real bug there. I have spent way more than I anticipated as well. I've even considered purchasing their custom support, but I don't think they can fix this either and from what I've heard on the forum, there's a lot of problems with that approach, in particular, followup support. I started listing suggestions for support and testing of templates, but concerned it would be too long here. I'll start a separate thread.

      The SEARCH ISSUE is critical. I'll put in a ticket and also keep my fingers crossed that Shaun can fix it.




      Comment


      • #4
        Regarding the search issue, If you're talking about it breaking on mobile only, I had it. It was broken by the 6.5 update. It was fixed on one of my sites. I still haven't gotten around to the other. Here's the explanation for the fix I got from support. I haven't gotten around to it. I hope this helps.

        The attached jquery code can be added to the head section of the site's frame file. This template can be modified via Settings > Design > Template Editor. You may need to use the 'Go to folder' drop down list to choose templates/common or your theme (it will be highlighted with yellow). Look for frame.html
        Code:
        <script type="text/javascript">
        if (typeof jQuery == 'undefined') {
        document.write("<script type=\"text/javascript\" src=\"/assets/templates/common-html5/js/jquery.min.js\"></" + "script>");
        }
        </script>

        Comment


        • #5
          Wow. They referred me to the Sales department. I switched to a different free template and no problems. Should have done it earlier. Live tracking showed visitors searching for words and leaving within 1 minute.

          Comment


          • #6
            Exactly what happened when people tried to search?
            - Dean P. e-commerce and small business consulting

            Comment


            • #7
              Hi DeanP,

              While the button displayed, nothing happened when it was clicked (that is, no search box appeared). It is really strange, it will work if you're on a product page, but not if you're on a "content" page like Home, Contact Us, a category page, etc.

              Support seems to be able to correct the issue, with the one caveat that Quick Search must be enabled. Unfortunately I was hoping to not have Quick Search enabled since it does not look correct on a mobile phone, but that appears to be the trade off to at least having a functional and working search feature with that template...

              -James

              Comment


              • #8
                Originally posted by JR123 View Post
                Hi DeanP,

                While the button displayed, nothing happened when it was clicked (that is, no search box appeared). It is really strange, it will work if you're on a product page, but not if you're on a "content" page like Home, Contact Us, a category page, etc.

                Support seems to be able to correct the issue, with the one caveat that Quick Search must be enabled. Unfortunately I was hoping to not have Quick Search enabled since it does not look correct on a mobile phone, but that appears to be the trade off to at least having a functional and working search feature with that template...

                -James
                I think that there's a very easy fix for this. I seem to recall the identical issue with quickview and I think that they're dependent on the same exact JS file. I think you can disable the function and manually add a reference to the quick_view.js file from the common in your frame's header.

                Comment

                Working...
                X