Announcement

Collapse
No announcement yet.

Help with centering text on home page

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help with centering text on home page

    I have a responsible theme. I am trying to center the text and images on my home page. I am using WYSIWYG and choosing center(middle) and it shows up there in the Store Manager as centered, but it is not changing it on my live site. I have cleared cache and reopened browser. Is the responsive theme overriding my settings? www.knot-dresses.com

  • #2
    Usually, text is surrounded by <p> and </p> tags. What you could do is change the tag to <p style="margin-left:auto; margin-right:auto;"> text here </p>. You could also change the CSS to reflect this if you wanted all sections to be centered, but if you wanted to do a specific area, you could just add the style inline.

    Comment


    • #3
      Thanks for the response jnnjr. I just really feel like there must be something overriding any change I make in Store Manager Home Page.

      This is the default which aligns left:
      <p style="margin-left:auto; margin-right:auto;" align="left"><span style="font-size: 14pt;">Boutique Elli'Ette is well known for the original, exclusive and best-selling Reverse Knot design which is offered as a dress or a bubble.</span></p>

      Changed to this which still aligns left:
      <p style="margin-left:auto; margin-right:auto;"><span style="font-size: 14pt;">Boutique Elli'Ette is well known for the original, exclusive and best-selling Reverse Knot design which is offered as a dress or a bubble.</span></p>

      Highlighted text and picked center and it still aligns left:
      <p style="margin-left:auto; margin-right:auto;" align="center"><span style="font-size: 14pt;">Boutique Elli'Ette is well known for the original, exclusive and best-selling Reverse Knot design which is offered as a dress or a bubble.</span></p>

      Comment


      • #4
        Hi Kat,

        There is a style in your default.css that is causing this. On line 853, you have this style:
        #homeHeader p, #homeFooter p {
        text-align: justify;


        }

        The justify style is setting everything to the left. You could change it to "center" and that would solve your issue. Or, remove it completely so the WYSIWYG editor can set the text alignment.

        Joanne Barker
        VS Web Design
        [email protected]

        Comment


        • #5
          Worked like a charm! I always want my content centered so that's perfect. Thank you vswebdesign!

          Comment

          Working...
          X