Announcement

Collapse
No announcement yet.

Page links have gone dead again

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Page links have gone dead again

    Hi: I had this problem a little while back and it's happened again. My page links (the ones across the very top of the page i.e. Home | About | Gift Registry | ........ the links have disappeared - not the text, but what they are supposed to link to. http://www.knot-dresses.com

    History: the first time it happened I had asked support how to get the categories area to show more categories and I was advised how to enlarge the area. The page links worked after that, for a few days. When they stopped working, forum advice helped me add some rules to default_modified so that the code wouldn't hide behind something (sorry I'm not a techy and don't remember the exact terminology) - anyway, that worked. BUT then I discovered that the site was not working on mobile and support told me it was because I was using default_modified and to go back to default and go back to default area for categories. So I went back to default and everything was working fine.

    Current: the only tweak I've made recently was adding a logo through settings > design > header and footer. I didn't like how it looked so I removed it.

    P.S. the Page links are working on mobile just fine - problem is only on pc (going to check on my tablet)

    I have submitted a ticket.

    Any advice? Oh, I called support also, they submitted the ticket. I have an event planned for tomorrow noon est and this situation is not good.




  • #2
    Yes, I see. I notice that your dynamic cart link is also not able to be clicked either. This leads me to believe that something transparent is over top of the links. Just a hunch. I had something similar happen to me once when I was messing around the header area.

    Have you tried disabling your Global Header to see if the links become usable? By Global Header, I mean the part that says "Call us: Mon - Fri 8am - 5pm pt ". I am assuming this text is in your global header area?

    Comment


    • #3
      The links are working properly for me on my desktop using Chrome. Did you implement a fix?

      Comment


      • #4
        Still not working for me. Latest version of Firefox.

        ProRetail: Are you sure you were clicking the links above the search bar and not the category links in the gray bar? That's what I did the first time I checked but then realized my mistake. lol Just wondering.

        Comment


        • #5
          I was clicking in the proper section. It looks completely different in Chrome versus Firefox. Looks like a spacing issue as the menu is being pushed down into the header section and being "hidden". You can either position it relatively and give it a z-index of 1000 (or lower if nothing else is using z-index) or figure out what is causing it to push down. I highly recommend FireFox Developer Edition for stuff like this.

          Comment


          • #6
            Yes, Global Header is turned off.

            Is it weird that the page links are working on mobile??

            Comment


            • #7
              If you global header is turned off, the how are you displaying the "Call us: Mon - Fri 8am - 5pm pt "?
              Last edited by toolsavvy; 06-26-2015, 04:47 PM.

              Comment


              • #8
                The links aren't broken, so it's not weird that it's working in mobile. Something in your menu bar is too wide causing it to be pushed out of the menu bar and behind the header. Since the links are behind the header when they're being pushed down clicks don't work. If you remove the height from .top-menu-bar in your css file the links should work again, but there's still a spacing issue that needs to be addressed.


                In case you're not CSS and HTML savvy, imagine your hand behind a piece of glass. You can see it, but if you try to touch it you can't. You're only able to touch the glass. That's what's happening with those links. They're being pushed down behind the header section. Hope that helps :)
                Last edited by ProRetail; 06-26-2015, 04:39 PM. Reason: clarity

                Comment


                • #9
                  I just checked in Chrome Version 43.0.2357.130 m and it's not working for me. Chrome tells me there are no new updates so this must be the latest version.

                  Comment


                  • #10
                    Thanks proretail and toolsavvy - I agree there is a spacing issue - I have not done anything since the first time this issue occurred - or at least not to any code - just added the logo in the Store Manager proper area, but then removed it.

                    Proretail - as far as Global Header being off - I attached a screen shot of where I'm looking at the settings - is there another place I should be looking? I don't want that displayed anyway but could never figure out how to get rid of it!

                    Comment


                    • #11
                      toolsavvy what is your screen size? The site is responsive and since it's a spacing issue, the smaller your screen the higher chance those links are being pushed down. Here's what I see in each browser:
                      Attached Files

                      Comment


                      • #12
                        I'd have to take a look at your templates to tell you for sure what needs to be changed. Any of my fixes above will at least make your links functional until you can adjust your CSS. I recommend you download FireFox Developer Edition. It has saved me so many hours it's not even funny. You can edit code right in the browser and see the outcome instantly. You can also inspect certain elements to pinpoint issues.

                        Comment


                        • #13
                          screen size on both browsers is set to 100%

                          Comment


                          • #14
                            what template are you using katalone?

                            Comment


                            • #15
                              cazza - and I just changed the width from 80% to 90% thinking that might help but it didn't - I don't even really know what that does but thought I'd try it lol

                              Comment

                              Working...
                              X