Announcement

Collapse
No announcement yet.

Review - Automatic Email Reminder | Code not Rendering Properly

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Review - Automatic Email Reminder | Code not Rendering Properly

    We recently updated our email from V2 to v3 and when doing so we noticed that there is a new section at the bottom of the email which is supposed to display related products for customers to view:



    We submitted a support ticket, however after 23 hours and 5 messages back and forth all we have gathered from that is that there are "Global Variables" which have been "copied" over from a past email. Again, we haven't modified this email at all so it appears that the developers used code that can't be rendered.

    Anyone else experiencing this? Here is the block of code in question:

    <!--START: related_items_review-->
    <table style="border-collapse: collapse;width: 200px;" align="left" border="0" cellpadding="0" cellspacing="0">
    <tbody>
    <tr width="100%">
    <td class="thumbnail" style="border-collapse: collapse !important;vertical-align: top;text-align: left;color: #333;font-family: 'Helvetica', 'Arial', sans-serif;font-weight: normal;line-height: 17px;font-size: 12px;margin: 0;padding: 10px 10px 10px 0;" align="left" valign="top">
    <a href="[store_url]/product.asp?itemid=[catalogid]">
    <img src="[store_url]/[THUMBNAIL]" alt="[name]" width="80" style="width: 80px !important; max-width: 100%; padding: 0 10px 0 0;" align="left">
    </a>
    </td>
    </tr>
    <tr width="100%">
    <td style="vertical-align: top;text-align: left;color: #333;font-family: 'Helvetica', 'Arial', sans-serif;font-weight: normal;line-height: 17px;font-size: 12px;margin: 0;padding:5px 20px 5px 0px;" align="left" valign="top">
    <span><a href="[store_url]/product.asp?itemid=[catalogid]">[name]</a></span>
    </td>
    </tr>
    <!--START: product_review-->
    <!--START: product_review_average-->
    <tr width="100%">
    <td style="vertical-align: top;text-align: left;color: #333;font-family: 'Helvetica', 'Arial', sans-serif;font-weight: normal;line-height: 17px;font-size: 12px;margin: 0;padding: 5px 0px;" align="left" valign="top">
    <img src="[store_url]/assets/templates/common-html5/images/star[review_average].png" alt="Average Rating">
    </td>
    </tr>
    <!--END: product_review_average-->
    <!--END: product_review-->
    <tr width="100%">
    <td style="border-collapse: collapse !important;vertical-align: top;text-align: left;color: #333;font-family: 'Helvetica', 'Arial', sans-serif;font-weight: normal;line-height: 17px;font-size: 12px;margin: 0;padding: 10px 0px;" align="left" valign="top">
    <!--START: ITEMPRICE-->
    [ITEMPRICE]
    <!--END: ITEMPRICE-->
    <!--START: SALEPRICE-->
    <del class="price2">[ITEMPRICE] </del>
    </br>
    <span class="hidden">[product_onsale] </span>
    </br>
    [ITEMSALEPRICE]
    </br>
    <div class="on-sale">[product_sale]</div>
    <!--END: SALEPRICE-->
    </td>
    </tr>
    <tr width="100%">
    <td style="word-break: break-word; -webkit-hyphens: auto; -moz-hyphens: auto; hyphens: auto; border-collapse: collapse !important; vertical-align: top; text-align: left; color: #333; font-family: 'Helvetica', 'Arial', sans-serif; font-weight: normal; line-height: 17px; font-size: 12px; margin: 0; padding: 5px 20px 5px 0px;" align="left" valign="top">
    <div class="status">
    <!--START: product_availability-->
    [availability]
    <!--END: product_availability-->
    </div>
    </td>
    </tr>
    </tbody>
    </table>
    <!-END: related_items_review-->
    Attached Files

  • #2
    Yeah, i think there are more than a few problems with the newer emails. I've noticed the variable [tracking_code] being displayed in a lot of the emails customers reply from.

    Comment


    • #3
      Having the same problem. Logged a ticket and going back and forth now.

      Comment

      Working...
      X