Announcement

Collapse
No announcement yet.

Site not redirecting properly via CNAME?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • reefadmin
    replied
    This issue has been resolved. I also needed to update the A Record at GoDaddy. I was configured, by default, to "Park". I had to update it with an IP address provided by Support. This wasn't mentioned when I followed the instructions for connected the store to the domain name. I will not list the IP here because it may not be the same for everyone. Up and running now, though, and wanted to follow up to help others.

    Leave a comment:


  • reefadmin
    replied
    Thank you very much for the quick response. I look forward to hearing from Support. Thanks!

    Leave a comment:


  • 3dcart-William
    replied
    reefadmin Thanks for reaching out regarding this. I will get this over to a support specialist and you should hear back about this soon. Also if you have any other issues feel free to email support directly at [email protected] .

    Leave a comment:


  • reefadmin
    started a topic Site not redirecting properly via CNAME?

    Site not redirecting properly via CNAME?

    I registered mydomain.com at GoDaddy and, later, signed up for 3dcart. For our store, which is new and still closed, I've been accessing the OSM via the mydomain-com.3dcartstores.com URL they provided me from a confirmation email. We've been tinkering with the software for a few weeks. From GoDaddy, I updated the CNAME for WWW that pointed to "@". The new config for this entry is for WWW to point to mydomain-com.3dcartstores.com. That was yesterday morning. Today, if I type www.mydomain.com into my browser, I'm taken to the store's closed page (we have this configured so this is correct) but the URL in the browser address bar updates to mydomain-com.3dcartstores.com. If I type mydomain.com into the browser, I'm taken to the GoDaddy parked page. For either case, with or without the www prefix, I'm hoping for the site to load and for it to not update the URL in the browser. I'm hoping that will remain as mydomain.com as customers are on our site. In Domain Settings for 3dcart, I see that both mydomain-com.3dcartstores.com and mydomain.com are both "Active" as well as both of those listed below with the HTTPS prefix and those are active as well. What changes can I make to get both www.mydomain.com and mydomain.com to display my store's site without updating the URL in the address bar? Any information you can provide will be much appreciated. Thanks!
    Last edited by reefadmin; 06-24-2020, 09:36 AM.
Working...
X