Announcement

Collapse
No announcement yet.

Errors with Google AMP

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Errors with Google AMP

    Is anyone else getting errors with the AMP pages within their Google Webmaster tools? We are getting errors on all of our pages and not sure why.

    Fix the following 2 issues:


    Invalid CSS stylesheet

    User-authored JavaScript found on page


  • #2
    Google systems have detected that some of your AMP pages do not meet our guidelines; therefore these pages are not eligible for AMP-related features in Google Search. The Accelerated Mobile Pages report lists some of these pages.

    Comment


    • #3
      Hello damiencaz sorry you're getting these messages from google regarding the guidelines. We can look into this for you, can you open support ticket with the list of pages? Once we have that information we can investigate whats going on and assist with getting the pages corrected.

      Comment


      • #4
        Originally posted by 3dcart-William View Post
        Hello damiencaz sorry you're getting these messages from google regarding the guidelines. We can look into this for you, can you open support ticket with the list of pages? Once we have that information we can investigate whats going on and assist with getting the pages corrected.
        Ticket submitted - thank you! I will share the results so it will help others.

        Thank you again - D!

        Comment


        • #5
          damiencaz Following. Please share when you find the fix. Thank you.

          Comment


          • #6
            Same issues with our store as well and I also sent in a ticket. Another error we had on top of what damiencaz mentioned was the incorrect img tag. Suppose to be <amp-img> not <img>

            Comment


            • #7
              JoeBTI Thanks for the information, I'll add this to the internal ticket with the development team. I think the solution will correct this as well but I'll still mention it in the details to be sure. Soon as I have more details I'll update everyone via this post. Thanks so much for your patience!

              Comment


              • #8
                Hello everyone, the developers are releasing an update to resolve this. Please allow up to 24hr while it's being deployed to test for the error. Thank again everyone for your patience!

                Comment


                • #9
                  Originally posted by 3dcart-William View Post
                  Hello everyone, the developers are releasing an update to resolve this. Please allow up to 24hr while it's being deployed to test for the error. Thank again everyone for your patience!
                  Thank you so much! Works great for us, we re-submitted the AMP urls within the Google Webmaster tools and you guys fixed it! Thank you so much! D

                  Comment


                  • #10
                    I had the same issue - submitted to helpdesk - the development team have fixed. So all good for the moment.
                    Sue
                    Fabric Garden
                    fabricgarden.com.au

                    Comment


                    • #11
                      3dcart-William We're still getting errors on our store for almost all products. Appears that any products with an image in the extended description gets an error. Still uses the <img> tag. IDK maybe nothing can be done about this...

                      Comment


                      • #12
                        JoeBTI There was another update release to resolve this. There were some other reports of this happening again over the weekend and the developers released another patch. Are you still getting these errors?

                        Comment


                        • #13
                          I am see the User-authored JavaScript found on page message as well. I'll submit a ticket.
                          - Dean P. e-commerce and small business consulting

                          Comment


                          • #14
                            Thanks DeanP , we have notified our developers. One of our technical account managers is currently gathering the data and escalating this.

                            Comment


                            • #15
                              JoeBTI Sorry this is happening now. Are you able to open a ticket with these details and the software you are using to test this? I can follow up on it afterward and make sure it gets attention.

                              Comment

                              Working...
                              X