Announcement

Collapse
No announcement yet.

Sudden problem with invalid images for Google

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Nader
    replied
    Danab what custom fields are you using to populate the google feed? For example UPC code and Condition: new. Did you place these in any particular Custom field?

    Leave a comment:


  • Danab
    replied
    Thought I would post an update. Today I am down to 15 items with invalid images (from over 70 at one point). Google has been re-activating the products slowly during recrawls but still cannot find the images/load the pages of about 1 product every day or so. I am guessing this is 3dcart server speed related but at least it is not as bad. Google goes back later and if it gets the pages to load fast enough it validates the images. I am not doing anything different on my end. I am hoping 3dcart will make some speed improvements or perhaps I can work on a new template next year. I am using the 3dcart template with just a few little changes and I am too scared to add anything new in case it makes the issue worse.

    Leave a comment:


  • Danab
    replied
    DeanP I checked the Google index and my images are in there. I didn't check all 4K lol but they are being indexed and the products being kicked out of Google shopping are still indexed in regular Google (just not shopping). I just have a drop in my overall ranking with the name change so hopefully that picks up in the next 6 months to a year. I was migrated over to a SQL database this morning so I will see if there are any changes over the next week. I went up to 50 then back down to 47 products affected yesterday. /shakesfist. Such an annoying issue so I am crossing my fingers!

    Leave a comment:


  • DeanP
    replied
    Danab - I came across this and thought it may be of interest to you. Take a look:

    https://3dcart.uservoice.com/forums/...image-indexing

    Leave a comment:


  • DeanP
    replied
    I wrote several responses back to you because the private messager kept truncating my message. Sorry for the mess.

    Leave a comment:


  • Danab
    replied
    And now that same page has 30 loading errors at 1:36 .........GAHHHH!!!!!!
    You do not have permission to view this gallery.
    This gallery has 1 photos.

    Leave a comment:


  • Danab
    replied
    DeanP I just PM'd the link to the feed as well. Thank you!

    Leave a comment:


  • Danab
    replied
    DeanP I will take a look at it in a bit.

    3dcart finally got back to me and said "Seems like this is an Issue with your Products and the way the images are attached to the site.". All of my images are attached too the site in the same exact manner so I have no idea what he is talking about. Just now I took one of the products that has this stupid error and ran it through the mobile checker at 12:54 today. There were five page resource loading errors including the image. I ran it again at 12:55 and it was back to that one weird one with the stats showing as an image re-direct. I just want to throw vegetables at them for suggesting I purchase their shopping feed app. (like that is going to fix this problem). Screenshots attached....
    You do not have permission to view this gallery.
    This gallery has 2 photos.

    Leave a comment:


  • DeanP
    replied
    You may have missed my earlier post above, #6. Let me know if you want another pair of eyes to look over some things.

    Leave a comment:


  • Danab
    replied
    Thanks for responding DeanP . I sent in a ticket a few days ago and have not heard anything back yet about the image access error. I have noticed that the issue started to slowly go down in numbers though so something might have been fixed somehow. It got up to 72 products then it has very slowly gone down to 55 as of today. The last product flagged was on 10/4/17. There's 3327 products in the feed that are OK. I cannot find anything wrong with the feed for the 55 remaining items with image access errors and Google could not say why it was happening either. If I hear back from 3Dcart on my ticket then I will post if they have anything that helps.

    I did find some other errors that may have occurred when my old store was cloned or it could have been from the version 8 upgrade where suddenly characters were in tab fields and some manufacturers fields (that were always blank for years) so I fixed all of those for the next feed upload. Those mystery characters in blank fields were immediately errored out when the feed was uploaded so not the same as the access image error which occurred a few weeks after the feed was uploaded. I also had the right column showing up on the site when it was hidden before and had to go back and re-check all those boxes etc. Shaun fixed another template bug for me too. So hopefully I am whittling through all the bugs.

    I want to try activating AMP but am trying to get some of these mysterious things cleaned up first. My site is scoring badly in yellow at 66% for mobile users even though it is responsive so I need to do something about it.
    Last edited by Danab; 10-06-2017, 02:12 PM.

    Leave a comment:


  • DeanP
    replied
    Originally posted by Danab View Post
    Why would something to do with stats cause google to have an image re-direction error on the mobile friendly test?
    Probably because the link in that screenshot isn't an image. In fact, it's not really anything; try visiting it.

    You can try disallowing count.asp in your robots.txt. Just add it to the bottom of the existing list like so:

    Code:
    # Disallow all crawlers access to certain pages.
    User-agent: *
    Disallow: /checkout.asp
    Disallow: /add_cart.asp
    Disallow: /view_cart.asp
    Disallow: /error.asp
    Disallow: /shipquote.asp
    Disallow: /rssfeed.asp
    Disallow: /mobile/
    Disallow: /admin/
    Disallow: /stats/count.asp
    or
    Disallow: /stats/
    Last edited by DeanP; 10-05-2017, 12:54 PM.

    Leave a comment:


  • DeanP
    replied
    Admin > Marketing > Shopping Engines > scroll to bottom

    Are you using Google Product Listing Ads in the lower left, or Google Product Feeds in the lower right?

    I'd like to see the feed you're sending to Google. Can you PM with either a link to it or an attached copy of it?

    Leave a comment:


  • Danab
    replied
    Here is my current robot.txt file which does not appear to have anything that woud hinder google from accessing any images.

    Sitemap: https://www.azureaster.com/sitemap.xml

    # Disallow all crawlers access to certain pages.
    User-agent: *
    Disallow: /checkout.asp
    Disallow: /add_cart.asp
    Disallow: /view_cart.asp
    Disallow: /error.asp
    Disallow: /shipquote.asp
    Disallow: /rssfeed.asp
    Disallow: /mobile/
    Disallow: /admin/

    User-Agent: twengabot
    Disallow: /

    User-agent: twenga2.com
    Disallow: /

    User-agent: twenga.com
    Disallow: /

    User-agent: Yandex
    Disallow: /

    User-agent: Baiduspider
    User-agent: Baiduspider-video
    User-agent: Baiduspider-image
    Disallow: /

    Leave a comment:


  • Danab
    replied
    Still having issues. Here is a SS of the only "error" I can come up with using the google mobile checker. Why would something to do with stats cause google to have an image re-direction error on the mobile friendly test? DeanP do you think this could be causing my invalid image issues and sudden product disapprovals by Google? Writing a ticket so trying to make sense. Here's some other things showing up on google page insights too. I don't think I can fix any of these either. This is a 3dcart template.

    Your page has 3 blocking script resources and 5 blocking CSS resources. This causes a delay in rendering your page.
    None of the above-the-fold content on your page could be rendered without waiting for the following resources to load. Try to defer or asynchronously load blocking resources, or inline the critical portions of those resources directly in the HTML.
    Remove render-blocking JavaScript:[LIST][*][url]https://www.azureaster.com/
    You do not have permission to view this gallery.
    This gallery has 1 photos.

    Leave a comment:


  • Danab
    replied
    I spent 30 minutes on the phone with a Google rep (in India) and got absolutely nowhere. He could not understand what the problem was. He told me to upload my feed again (which I did) and the issue continues. I am going to have to submit a ticket to 3dcart I guess and try Google again next week. I am now up to 63 products with the error accessing the image issue.

    Would someone mind checking their Google merchant account to see if they are having a similar issue with their product feeds showing invalid images?

    Leave a comment:

Working...
X