No announcement yet.

Need help with google product upload. Can not add topic anyplace else

  • Filter
  • Time
  • Show
Clear All
new posts

  • Need help with google product upload. Can not add topic anyplace else

    I did just move back to 3dcart from shopify. I can not get my products to upload without errors. First I get this Export Utility

    Export is in progress. Please leave this window open until the export is 100% complete.

    Microsoft VBScript runtime error '800a0009'

    Subscript out of range: '[number: 17]'

    /admin2/includes/Exp_Imp_Class.asp, line 1338. Can some one help me clear this. I have had a help ticket submitted for two days no answer

  • #2
    [email protected] Sorry you are getting this error when attempting to upload your products in the store. You mentioned submitting a ticket, may I have the id ? I can get someone to look into it right away.


    • #3
      the ticket number is TEQ-652-87434 Thanks for any help you can give


      • #4
        Did you ever get this resolved? We had a similar issue importing any file, products, orders, etc. I learned that the error can be caused by some really difficult to troubleshoot issues with classic ASP and the way a browser might trim line feeds and carriage returns and such. As a workaround we have been able to do the uploads in Chrome without error, but I'd like it to work in any modern browser.

        On a related note the newest Excel has added a few new types of CSV like UTF-8 encoded and some others, we've seen that cause the occasional issue pretty much everywhere. So if you are using Excel make sure to save it as a regular csv.


        • #5
          In case it helps anyone else we learned a few more things about these (or at least similar) problems.

          First if you are using a proxy like Cloudfront or Incapsula that might be causing these issues. We learned that Incapsula at least causes problems with many ASP and applications because of the way they handle header parsing and cookies. They intentionally include corrupt headers and cookies to help filter out bots. That does the job, but unfortunately it can cause all sorts of bizarre issues with Microsoft products (or anything that won't accept UnsafeHeaderParsing) . Even stuff like Excel can have problems with their basic web import stuff if you are running over Incapsula. The most frustrating part is that not everyone always gets the "bad" cookies or headers. Our server we use for importing orders worked for awhile after switching to them, then failed. I cleaned its cache and rebooted it and it ran fine again for a long time, and then started failing again when it got a new "bad" cookie.

          After switching off of Incapsula the problems with the API and uploads went away, BUT you have to completely empty your browsers cache, all cookies, etc. That tricked me the first time I tested it because I cleared the cache on my browser and pointed myself directly to our server, bypassing Incapsula. The problem still occurred, but what I didn't realize at the time was that I still had corrupt cookies in there, so even though I wasn't going through Incapsula the corrupt cookies were still causing failures.


          • #6
            Checked the file for bad characters?


            • #7
              Last time I tried to upload google feed every item was disapproved and I lost the sreadsheet formula. Does anyone have the correct way to set up our google feed. Thanks very much for your help


              • #8
                sorry [email protected]