Announcement

Collapse
No announcement yet.

Proper use of system variables?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • maksum
    replied
    That's a good question. Seems that sometimes it posts for me and other times it does not. I've had to add spaces to the < and > parts of tags and placed a note to omit the spaces. Othertimes it posts just fine if I use the [ code ] tags.

    :confused:

    Leave a comment:


  • StuTheDog
    replied
    Thanks, I've taken to hardcoding the layout name but like your suggestion of assets/images better...

    On another note I sent you a private email asking if you could elaborate to this thick skull what I need to do to paste code on this board? I used the [CODE] tags but they seem to get ignored, so if I try pasting some html that defines table elements the board attempts to render them rather than display the code. Check out my latest post in feature requests...

    Thanks, I'm learning a lot from you!

    Steve

    Leave a comment:


  • maksum
    replied
    Yeah, I've noticed that some files take those variables and others do not. These are the alternate routes I take:
    • If you're not planning on swapping out your templates, just throw the template name in there
    • Place the image in the common folder and reference it there (as long as it's a unique image and not one that 3dcart may update)
    • Place the image in "assets/images/" and reference it there.


    Just my thoughts.

    Leave a comment:


  • StuTheDog
    started a topic Proper use of system variables?

    Proper use of system variables?

    Hi, I'm trying to display an image for my home page, but the system fails to substitute [template] in the code below. This code is in the Header portion of Home, I've also tried dropping it directly into Home.html.

    Code:
    <TABLE style="WIDTH: 100%; BACKGROUND: #ffffff" id=Table1 border=1 border-color=blue cellSpacing=3 cellPadding=3>
    <TBODY>
    <TR>
    <TD class=data>
    <img src="assets/templates/[template]/images/home.gif" alt="" >
    </TD></TR></TBODY></TABLE>
Working...
X