Announcement

Collapse
No announcement yet.

duplicated category header/footer content

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • duplicated category header/footer content

    Here's another bug I am running into...

    if I use
    <!--START: CATEGORY_HEADER-->
    [CONTENT]
    <!--END: CATEGORY_HEADER-->
    <!--START: CATEGORY_FOOTER-->
    [CONTENT]
    <!--END: CATEGORY_FOOTER-->

    in my category_x file, I get duplicate content. Basically, it repeats both the header and footer fields' content.

    If I have these in my category_x file and only put content into one of the header or footer fields (for that cat), it duplicates whatever is there (whichever field has content)...

    If I put some content into the header field and some into the footer field, but ONLY have the
    <!--START: CATEGORY_HEADER-->
    [CONTENT]
    <!--END: CATEGORY_HEADER-->

    in my category_x file, it displays the content of both ANYWAY.

    This is the stuff that bugs and confuses the hell out of me... I mean, I *could* wrap my head around the fact that it simply doesn't work correctly, but it limits what I can do and takes away the ability to use one of those fields somewhere else - since I don't (obviously) want the content duplicated ever.

    bug? known bug? :eek:

  • #2
    This is one for the support team, I've have seen this work, so it may be something specific to your setup, please submit a support ticket with a link to a template that they can see, so that they can troubleshoot it further.

    If you open one of the default templates, do you see this behavior as well, or only on the custom one you created?
    ----------------------------
    Gonzalo Gil
    3dCart Support
    800-828-6650 x111

    Comment


    • #3
      Originally posted by GonzaloGil View Post
      This is one for the support team, I've have seen this work, so it may be something specific to your setup, please submit a support ticket with a link to a template that they can see, so that they can troubleshoot it further.

      If you open one of the default templates, do you see this behavior as well, or only on the custom one you created?
      It could be just on mine... I'm not sure but I can't see why that should be... are these fields NOT discreet areas? It's like... if you have both the <!--START: CATEGORY_HEADER--> and <!--START: CATEGORY_FOOTER--> tags (with the end tags, of course) with [CONTENT] in there, it duplicates, no matter where the content is (header or footer field or both). But, if I have the content in the header AND footer fields and ONLY use the start:header tags (correctly implemented, I'm just tired of writing the same thing over and over)... it STILL shows the content from both the header and footer field.

      TOO WEIRD. The default category_0 template file (in common) has a lot of other stuff between these two tag groups... but other than tables being INSIDE them (rather than images <img>) (or even text written like "stuff here")... I don't see anything special about them in the default file. It just doesn't make sense.

      These tags... they simply copy the content into the same area where the [CONTENT] marker is, right?

      Honestly, I just don't have the time to puzzle out these vague behaviors...

      As much as I hate it, I'll just have to leave one of them out and get moving forward... :eek:

      Comment


      • #4
        duplicated category header/footer content (FIX)

        Wow, I cant believe this has been a problem since 2007. For shame!

        I found out what the bug was thanks to help from Andrew. The category header and footer content tags need to be different. See below...
        WONT WORK...
        <!--START: CATEGORY_HEADER-->[CONTENT]<!--END: CATEGORY_HEADER-->
        <!--START: CATEGORY_FOOTER-->[CONTENT]<!--END: CATEGORY_FOOTER-->

        FIX:
        Strangely, the only thing that works is if there is space between the header tag and the header content block...
        <!--START: CATEGORY_HEADER--> [CONTENT]<!--END: CATEGORY_HEADER-->
        <!--START: CATEGORY_FOOTER-->[CONTENT]<!--END: CATEGORY_FOOTER-->


        If the space is somewhere in the footer block -> wont work.
        If the space is after the header block -> wont work....

        Comment


        • #5
          Ongoing issues since 2007

          Good Morning,

          Please accept my apology for any inconvenience that you may have encountered through out this process. I noticed that Gonzalo replied to your post and stated to “submit a support ticket with a link to a template that they can see, so that they can troubleshoot it further.

          If you open one of the default templates, do you see this behavior as well, or only on the custom one you created?”

          Did you ever get a chance to submit a ticket to our Support Department? If you like I can have one my staff members look into this matter and see if we can find a resolution for you.

          Thank you for your patience.

          Yours truly,
          Fernando Panjoj
          Chief Customer Officer
          3DCart Shopping Cart Software

          Comment


          • #6
            I did submit a ticket. Andrew is the one who suggest I revert to 3dcarts template to see if it worked in that case. It did, but only because the tags surrounding the content block were different.

            <!--START: CATEGORY_HEADER-->
            <table width="100%" cellspacing="0" cellpadding="2" border="0">
            <tr>
            <td class="data" colspan="2">[CONTENT]</td>
            </tr>
            </table>
            <!--END: CATEGORY_HEADER-->


            <!--START: CATEGORY_FOOTER-->

            <tr>
            <td colspan="2" class="data">[CONTENT]</td>
            </tr>

            <!--END: CATEGORY_FOOTER-->

            Apparent if the content around the header and footer are the same, it wont work. He mentioned he was sending the bug to 3dcart developers to ensure others were aware of it.

            Comment

            Working...
            X