Announcement

Collapse
No announcement yet.

drop down menu active color

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • drop down menu active color

    I want to have my menu links stay black (from grey) when i am on selected page. Usually it is not that hard to do but the menu uses a completely different css file. I have tried putting some css myself but i cannot get the right version to make it stay black.

    The site i am working on is Welcome to Vanko Trading Corp. (survivalcampingworld.com) - Sample Slogan. any help would be greatly appreciated.

    Thanks!

  • #2
    You need to change it in your "menu.css".

    path in ftp is templates-->"your template"-->ddmenu

    Hope this helps.

    I read your post too quick... In the menu.css you will have to add a.selected, and a:active to (I believe) #dd_menu .MenuItemHover and in the css you will have to set color: #000000;

    so it should look like this:

    Code:
    #dd_menu .MenuItemHover a.selected a:active {
    	background: transparent;<---- You can disregard this, I just put it in as another variable-->
    	color: #000000;
    }
    I think...lol

    I'm not trying it right now so this is off the top of my head
    Last edited by GlowExpress; 01-06-2012, 01:27 PM.

    Comment


    • #3
      I add it to ddmenu but it didnt seem to do anything. Maybe i did not place it in the right spot in the css file. I put it towards the end before the spry information.

      Comment


      • #4
        you'll actually replace the css that's already there. If I remember right it is usually around line 145 or 150 of the menu.css.

        The code "title" is already specified as:

        #dd_menu .MenuItemHover {
        yadda yadda:yadda;
        }

        This is the one that you will need to change. If you add a duplicate it will revert. So you don't want duplicate css rules in the same file.

        Also make sure that you clear your cache if you have it checked in settings. You will not see any changes until you clear it if you have it set to cache.

        Also I think you might be able to get away with using a:active alone.

        so the replacement for above will look like this:

        #dd_menu .MenuItemHover a:active {
        background: transparent;<---- You can disregard this, I just put it in as another variable-->
        color: #000000;
        }

        If that doesn't work... try changing the "a:active" to ".active a"

        As soon as I get back tonight I can look at it closer.

        Comment


        • #5
          Didn't work.. I will hopefully be able to find a solution for you by morning

          Comment


          • #6
            Why thank you for trying that for me. Thanks for the help as well. Let me know if you figure anything out.

            Comment

            Working...
            X