Announcement

Collapse
No announcement yet.

remove "Items on Sale" and frame.html issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • remove "Items on Sale" and frame.html issues

    two things...

    1 - i would like to remove the "Items on Sale" that shows up on the main page. Can someone point me in the right direction to do that?


    2 - Also, i have edited my frame.html and everything worked out great all except for when you add something to cart things get a little weird.

    This shows up on the cart above the added items
    Code:
    table width=100% border=0 cellspacing="0" cellpadding="0">
    I looked for any extra code like this in the frame.html and everything appears to be needed.

    and again only when you add something to the cart... the paypal image and link i added below the cart moves to the left side and goes way down on the bottom. I wouldn't mind it moving to the left side if it were not so far down... weird.

    Here's a link to my site if you want to try it out and see for yourself... http://www.bpbponline.com

    i can add the code i use for the frame.html here if anyone's interested.

    Thanks!!

  • #2
    Since I changed this so long ago on our sites, I don't remember exactly what I did to remove the "Items on Sale" products. I may have deleted some code in the Home.html Template found under Setting>>Design>>Template Editor.

    Also, I don't know if you fixed this already, but I didn't see the code you were speaking of after adding something to the cart.

    Nice site by the way...

    Comment


    • #3
      1 - i would like to remove the "Items on Sale" that shows up on the main page. Can someone point me in the right direction to do that?
      If you are just talking about removing the text "Items on Sale" then you would have to do this in the home.html file which would be found in either the folder your templates are in or the common folder.

      You will see that it has a line of code that says:
      Code:
      [category_Header-specials]
      This is the code that calls the "Header-specials" field from the database. You could either delete this and adjust the surrounding code if necessary or you could go into Store Language and change it to say whatever you like. You could even try deleting the entry in this field and see if it removes the text from your home page.

      2 - Also, i have edited my frame.html and everything worked out great all except for when you add something to cart things get a little weird.
      I see it and I think your problem would be handled through the frame.html, look for this code:
      Code:
      <!--START: SHOPPING_CART_ITEM-->table width=100% border=0 cellspacing="0" cellpadding="0">
      and try adding a "<" right after the "-->" and before the words "table width..."

      Comment


      • #4
        1st issue fixed... still puzzeled the 2nd issue

        Thanks for tip about [category_Header-specials]... that did it!!

        on the 2nd issue... with the coding problem... I went back and checked my frame.html file and the < is there... i attached my frame.html so that you could take a look.

        Code:
        <!--START: SHOPPING_CART_ITEM--><table width=100% border=0 cellspacing="0" cellpadding="0"><tr><td class="cart-text" colspan=2>[ITEM_NAME]<!--START: itemoptions--><br><a href='#' onClick="toggle('opt[ITEM_ID]')">View/Hide options</a><br><div id=opt[ITEM_ID] name=opt[ITEM_ID] style="display:none;">[OPTIONS]</div><!--END: itemoptions--></td></tr><tr><td valign=top align=left class="cart-text"><input class="input1" type="text" name="qtyitemnum" value="[ITEM_QUANTITY]" size="3" maxlength="5"><input type="hidden" name="coliditemnum" value="[ITEM_ID]"></td><td class="cart-text" valign=top align=right><strong>[ITEM_PRICE]</strong></td></tr><tr><td colspan=2 class="top" height="1"><img src="spacer.gif" width="95" height="1" alt="" border="0"></td></tr></table><!--END: SHOPPING_CART_ITEM-->

        Thanks a million for the help!

        btw. thanks for the comment about my site ScribeTime.
        Attached Files

        Comment


        • #5
          I downloaded and checked out your file, but I don't see anything wrong after a quick pass. You may want to contact support.

          One last thought is to make sure you are looking at the correct frame.html file since there is one in every template folder as well as the common and possibly default folders.

          Comment


          • #6
            i was thinking that myself... i just wanted to throw it out here to make sure first. We'll see what they have to say.

            Comment


            • #7
              My response from 3dCart support... not exactly what i was hoping for...lol. So, i guess i will just hope some bored coder see's my posts and makes the discovery for me. :confused:


              ---------- Forwarded message ----------
              From: 3dCart Support <[email protected]>
              Date: Mon, Apr 28, 2008 at 8:18 AM
              Subject: [#KEU-277083]: odd issue only when adding something to the cart
              To: [email protected]

              shana,

              for the frame.html make sure that all your tables are properly opened and closed. if you would like we can either resolve this for $60(1 hour) or we can restore the original frame.html for you to work on for free

              this has to do with the table issue you are having in the shopping cart. once you resolve that issue it will fix the paypal image issue

              If you need further assistance with this issue please respond to this ticket with any quesitons/comments you may have. If you need assistance with a separate issue please submit a separate support ticket and we will be happy to help you.

              Carlin Canales
              Web Developer
              [email protected]
              1.800.828.6650 opt. 2
              http://www.3dcart.com
              http://support.3dcart.com

              Ticket Details
              Ticket ID: KEU-277083
              Department: Design Questions
              Priority: Normal
              Status: Waiting for Response

              Comment


              • #8
                I don't know if it will help - but I was having issues with my Paypal logo too. To get-around this (namely because I got tired trying to figure it out), I wound up inserting the Pay Pal logo in the footer, but after receiving some sort of warning message which might freak out some customers due to the html links Pay Pal has in there, I then changed it by adding the pay pal logo as an image (uploaded it to the FTP), which removed the direct links to pay pal which was giving me the warning messages. I adjusted the height width on the portrait one just a bit and found it looked better in the Right Banner as stricly an image with a mouseover/out popup with "Pay securely and privately with Pay Pal" text box.

                Always have issues in the frame template :(
                J-Lynn

                Comment


                • #9
                  Originally posted by JLynn View Post
                  I don't know if it will help - but I was having issues with my Paypal logo too. To get-around this (namely because I got tired trying to figure it out), I wound up inserting the Pay Pal logo in the footer, but after receiving some sort of warning message which might freak out some customers due to the html links Pay Pal has in there, I then changed it by adding the pay pal logo as an image (uploaded it to the FTP), which removed the direct links to pay pal which was giving me the warning messages. I adjusted the height width on the portrait one just a bit and found it looked better in the Right Banner as stricly an image with a mouseover/out popup with "Pay securely and privately with Pay Pal" text box.

                  Always have issues in the frame template :(
                  J-Lynn

                  Actually this did help... after reading your post i moved my PayPal box above the Cart and now it stays put. Im still getting the coding error tho... one down one to go. Thanks for the tip!!

                  Comment

                  Working...
                  X