Announcement

Collapse
No announcement yet.

Since 9.0 update navigation through categories goes to index page/homepage only.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Since 9.0 update navigation through categories goes to index page/homepage only.

    Since 9.0 update navigation through categories goes to index page/homepage only.

    www.caoh.com

  • #2
    That's not happening on either of my sites. Your category index is correct but for some reason, your site is redirecting the browser from your custom filenames. You should contact support.

    Comment


    • #3
      Originally posted by bzeltzer View Post
      That's not happening on either of my sites. Your category index is correct but for some reason, your site is redirecting the browser from your custom filenames. You should contact support.
      I did Yesterday no response. Each page and category has a custom file name as well as each product - if fact nearly page has a custom page.html.

      Are your review stars working correctly?

      I have updated Custom File Names in SEO tools and cleared cache. - This is weird.
      Last edited by kelly; 03-27-2019, 06:18 PM.

      Comment


      • #4
        kelly

        Remove your sumo top bar, clear cache and refresh. Some styles for the bar are forcing themselves onto the body tag of your frame and may be the issue since they may not be able to resolve properly

        Here is what your opening body tag looks like code side:

        HTML Code:
        <body class="home-page noleftbar norightbar qv-enabled not-logged-in" data-currency="$" data-decimal="2" data-sumo-smart-bar-data="{&quot;originalInlineStyles&quot;:{&quot;top &quot;:&quot;&quot;,&quot;bottom&quot;:&quot;&q uot ;,&quot;marginTop&quot;:&quot;&quot;,&quot;margin B ottom&quot;:&quot;&quot;},&quot;originalOffset&quo t;:{&quot;top&quot;:&quot;auto&quot;,&quot;bottom& quot;:&quot;auto&quot;},&quot;originalOffsetTop&qu ot;:0,&quot;originalTransition&quot;:&quot;&quot;, &quot;originalInlineTransition&quot;:&quot;&quo t;, &quot;originalMarginTop&quot;:&quot;0px&quot;,& quo t;originalMarginBottom&quot;:&quot;0px&quot;}" style="margin-top: 52px;">

        Doesn't hurt to try the removal just to see.

        The other reason is that your issues are before your categories. Some of your top menu links do the same so I don't see it as a pin pointed category issue. The only thing really before your top menu links is the body tag.
        Last edited by thecartdesigner; 03-28-2019, 06:52 PM.
        TheCartDesigner.com
        Not 3dcart Owned or Operated
        100% Independent 3dcart Expert


        Follow Us on Twitter

        Comment


        • #5
          I just saw you removed and the issue still exists. Have you checked your menu items or categories to see if there is something in the "link" area? I have seen this happen accidentally when people use csv to upload.

          I have version 9 on quite a few stores and no issue so it seems that it would be something internal
          TheCartDesigner.com
          Not 3dcart Owned or Operated
          100% Independent 3dcart Expert


          Follow Us on Twitter

          Comment


          • #6
            Originally posted by thecartdesigner View Post
            kelly

            Remove your sumo top bar, clear cache and refresh. Some styles for the bar are forcing themselves onto the body tag of your frame and may be the issue since they may not be able to resolve properly

            Here is what your opening body tag looks like code side:

            HTML Code:
            <body class="home-page noleftbar norightbar qv-enabled not-logged-in" data-currency="$" data-decimal="2" data-sumo-smart-bar-data="{&quot;originalInlineStyles&quot;:{&quot;top &quot;:&quot;&quot;,&quot;bottom&quot;:&quot;&q uot ;,&quot;marginTop&quot;:&quot;&quot;,&quot;margin B ottom&quot;:&quot;&quot;},&quot;originalOffset&quo t;:{&quot;top&quot;:&quot;auto&quot;,&quot;bottom& quot;:&quot;auto&quot;},&quot;originalOffsetTop&qu ot;:0,&quot;originalTransition&quot;:&quot;&quot;, &quot;originalInlineTransition&quot;:&quot;&quo t;, &quot;originalMarginTop&quot;:&quot;0px&quot;,& quo t;originalMarginBottom&quot;:&quot;0px&quot;}" style="margin-top: 52px;">

            Doesn't hurt to try the removal just to see.

            The other reason is that your issues are before your categories. Some of your top menu links do the same so I don't see it as a pin pointed category issue. The only thing really before your top menu links is the body tag.
            I tried the Sumo top bar removal and it seem to be a no go. I have determined that it has to do with the custom file name for the categories. Example I removed the custom name for all retail products (top left) and that one works now.

            Can you be more specific on the last part of your comments "The only thing really before your top menu links is the body tag."

            Thanks for the input - a ticket is in and being escalated, but its be 2 days.

            Comment


            • #7
              In other words if it was a direct html issue and the first sign of the issue was the top menu links, the issue if in html would typically be physically before the top bar menu links area.
              TheCartDesigner.com
              Not 3dcart Owned or Operated
              100% Independent 3dcart Expert


              Follow Us on Twitter

              Comment


              • #8
                I handled the category issue by removing the category custom file names. This basically created hours of fixing advertising campaigns and links in blogs, etc... so url's landed properly - what a mess. As for the review issues we decided to simply switch templates and start for scratch. All this did resolve both issues, but it sure created a ton of work.

                As of this post 3dcart has not addressed the problem or offered any support - the ticket is just sitting open. I have to admit I find this very frustrating and not very cool. All this headache simply because 3dcart updated to Version: 9.0.4. And why on earth would one a template change fix the broken review issues unless that template was broken. But heaven forbid 3dcart admit that!

                On templates does anyone now how to clean the templates to defaults - start with fresh settings with no history? The reason I ask is because now we get an error on recently viewed items when someone goes to a category page. I sent in a ticket, but they seem to think its something I did to the templates. The only edits I have made to the default is adding google tag manager, changing the logo size and editing the colors through the template editor menu selections. I just want to bypass all this and 3dcart support and set everything anew.

                Site: www.caoh.com

                Comment


                • #9
                  kelly

                  There are a couple ways to do this:

                  1. in the admin panel file manager, go to the file in question, scroll to the bottom and click "original version" clear store cache and refresh (sometimes you need to go back in the file and put a simple space somewhere and then save again so it registers as an "Updated". That way you always have your previous backup listed right int he admin with a timestamp

                  2. Go to FTP delete ONLY the file in question (Download the your template to your comp first so you have a physical backup of your template folder with all of the files). But this will make the system use the core template file (just make sure you don't delete your frame)

                  3. In FTP you can download the "CORE" template folder. Open the file in question on your computer. Copy the html and paste to your file in the admin panel. save, etc, etc
                  TheCartDesigner.com
                  Not 3dcart Owned or Operated
                  100% Independent 3dcart Expert


                  Follow Us on Twitter

                  Comment

                  Working...
                  X